Pic de pollution sur les pictos...?

mauguier
Messages : 19382
Enregistré le : 27 oct. 2008 08:35

Pic de pollution sur les pictos...?

Messagepar mauguier » 08 déc. 2016 16:51

Le brouillard est partout, les pictos s'affichent un dixième de seconde et disparaissent :shock: et ce n'est pas dû aux couches "cartes"....
Claude Mauguier

Dominique
Administrateur du site
Messages : 7013
Enregistré le : 29 juin 2016 18:15

Re: Pic de pollution sur les pictos...?

Messagepar Dominique » 08 déc. 2016 19:46

Ventre Saint Gris ! CampToCamp à déménagé ! Entraînant avec lui un naufrage informatique des autres couches :calimero: .
Donc couche C2C désactivée avant que je ne retrouve où elle est allée.
Il reste les autres...
Dominique

mauguier
Messages : 19382
Enregistré le : 27 oct. 2008 08:35

Re: Pic de pollution sur les pictos...?

Messagepar mauguier » 08 déc. 2016 20:20

Dominique a écrit :...CampToCamp à déménagé !...
Bah, il y a longtemps qu'ils déménagent, non ? :sleep:
Claude Mauguier

Dominique
Administrateur du site
Messages : 7013
Enregistré le : 29 juin 2016 18:15

Re: Pic de pollution sur les pictos...?

Messagepar Dominique » 08 déc. 2016 21:14

Je viens de faire un tour sur leur site, j'ai l'impression qu'ils ont viré les refuges, ...
Ex: https://www.camptocamp.org/huts/104105/ ... e-la-selle
Tu peux voir si tu trouves une liste ou une carte ?
Sinon, je vais virer tout lien avec C2C
Dominique

Dominique
Administrateur du site
Messages : 7013
Enregistré le : 29 juin 2016 18:15

Re: Pic de pollution sur les pictos...?

Messagepar Dominique » 08 déc. 2016 21:15

On trouve les points, mais fiches pas très fournies
https://www.camptocamp.org/waypoints/79 ... m-detoiles
Dominique

mauguier
Messages : 19382
Enregistré le : 27 oct. 2008 08:35

Re: Pic de pollution sur les pictos...?

Messagepar mauguier » 08 déc. 2016 21:51

Par exemple, le refuge des Ecrins existe (dans la catégorie "point de passage"), mais celui de la Pilatte a disparu.... C'est incohérent.
De toute manière, vu que le bordel C2C semble s'amplifier au lieu de diminuer, je pense que le retrait pur et simple des références C2C est la seule solution... On finira bien par retrouver nos petits, entre WRI, PRC et chemineur; le boulot supplémentaire ne me rebute pas ;)
Il y a bien 1635 "points de passage" référencés (tous abris confondus) et on doit pouvoir les identifier sur la carte latérale de droite. Mais bon...
Claude Mauguier

mauguier
Messages : 19382
Enregistré le : 27 oct. 2008 08:35

Re: Pic de pollution sur les pictos...?

Messagepar mauguier » 09 déc. 2016 08:59

Je reprends la discussion
- en confirmant que les points C2C affichent un picto type "refuge gardé" y compris pour les abris pourris.
- ces mêmes pictos aboutissent sur une 404 (pas Peugeot)
- il me revient en mémoire qu'hier, juste avant que je ne m'aperçoive de la disparition des pictos, j'étais sur WRI en train d'explorer le secteur "Lagorai" (peu importe d'ailleurs) en constatant qu'à part chemineur, c'était le grand vide...j'ai donc appelé l'option "points chemineur" et lorsque j'ai cliqué sur un (puis deux, trois...) picto , j'ai abouti sur un bec avec le commentaire "internal server error", à la suite de quoi je me suis dit que tu travaillais peut-être dessus. Après quoi j'ai constaté de visu que ça n'allait pas ici.

Remarque liminaire : avec la solution automatique "tout import" à l'égard des sites extérieurs (liens + pictos + images), quels qu'ils soient, il apparait évident qu'on importe aussi les bugs et autres véroles possibles...et là, à moins d'un test de compatibilité préalable, on va dans le brouillard. La preuve....

Je me demande si on n'aurait pas avantage à limiter l'importation à une solution "à la demande" (comme lorsqu'on est sur WRI : on clique l'option "chemineur"sur les cartes, mais ça n'importe pas sur WRI l'intégralité du contenu d'une page : on est renvoyé via une icone à un point extérieur à WRI et WRI ne subit pas de dommage collatéral en cas de pépin.
Claude Mauguier

Dominique
Administrateur du site
Messages : 7013
Enregistré le : 29 juin 2016 18:15

Re: Pic de pollution sur les pictos...?

Messagepar Dominique » 09 déc. 2016 11:34

Bonne analyse.
En fait, ce que tu décris est bien la base de l'architecture logicielle de chemineur 3 : être aussi indépendant que possible des sites externes.
Les points et commentaires externes ne sont pas dans la base mais superposés à l'affichage, ce que chemineur 3 aurait dû gérer simplement en ne les affichant plus.
Le sélecteur de couche chem/wri/c2C/... est bien dispo sur chem (sélecteur inférieur). Par contre, il pourrait ne pas sélectionner les sites externes par défaut.

Le problème c'est que je n'avais pas testé les effets de bords de la disparition pure et simple d'un site qui a généré un erreur technique irrécupérable et fait planter le serveur, ce qui a empêché la suite de se dérouler (affichage des points chemineurs, ...) bien que ça n'aie rien à voir !

Actions maintenant:
- blinder les programmes d'interface pour qu'ils gèrent sainement des arrêts de sites (qui peut simplement être temporairement inaccessible)
- ré-interfacer les "points de passage" du nouveau C2C. Par contre, les dédoublonages déjà faits seront à refaire car les références des nouveaux points de passage n'ont rien à voir avec les anciens "huts" :(
Dominique

mauguier
Messages : 19382
Enregistré le : 27 oct. 2008 08:35

Re: Pic de pollution sur les pictos...?

Messagepar mauguier » 09 déc. 2016 14:22

Dominique a écrit :- ré-interfacer les "points de passage" du nouveau C2C. Par contre, les dédoublonages déjà faits seront à refaire car les références des nouveaux points de passage n'ont rien à voir avec les anciens "huts" :(
Heu, est-ce à dire qu'il faut réorienter (puisqu'ils ne font pas partie de la base chemineur), ou plutôt reréférencer les liens de renvoi des 1635 "points de passage" C2C à la main...? Là, je prends un congé maladie aux Kerguelen... :o
Claude Mauguier

Dominique
Administrateur du site
Messages : 7013
Enregistré le : 29 juin 2016 18:15

Re: Pic de pollution sur les pictos...?

Messagepar Dominique » 09 déc. 2016 14:37

1635 peut être pas, n'empêche que les liens vers C2C sont morts.
Par ex celui dans: viewtopic.php?t=324

C'est un progrès par rapport à chem2 car les fiches auraient disparues en laissant les commentaires orphelins !
Mais il reste le pb que les liens sont cassés.

Je vais regarder si on peut les réidentifier globalement.
Sinon, je les supprimerai et on aura des doublons sur la carte...

Dans un premier temps ne touche à rien.
Par contre, ce ne sera pas tout de suite parce que je suis un peu occupé à d'autres choses :)
Dominique

mauguier
Messages : 19382
Enregistré le : 27 oct. 2008 08:35

Re: Pic de pollution sur les pictos...?

Messagepar mauguier » 09 déc. 2016 14:50

Je viens de vérifier d'ailleurs que sur WRI le même bazar était apparu :
- erreur 404 pour C2C
- erreur 500 pour chemineur
On n'est pas pressés ceci dit. Bon courage en attendant ;)
Claude Mauguier

Dominique
Administrateur du site
Messages : 7013
Enregistré le : 29 juin 2016 18:15

Re: Pic de pollution sur les pictos...?

Messagepar Dominique » 09 déc. 2016 14:55

Hum. Oui, c'est bizarre, sur WRI on voit des pictos C2C ... avec des liens morts

Bon. La bonne nouvelle, c'est qu'on peut retrouver les nouveaux liens avec les anciens:
ancien : https://www.camptocamp.org/huts/113328
nouveau : https://www.camptocamp.org/waypoints/11 ... gfluehutte
Le 113328 est inchangé.
Reste à écrire le programme qui va faire la traduction...
Dominique

Dominique
Administrateur du site
Messages : 7013
Enregistré le : 29 juin 2016 18:15

Re: Pic de pollution sur les pictos...?

Messagepar Dominique » 10 déc. 2016 22:58

Voilà. La base C2C est de nouveau interfacée.

Noter que, maintenant, tous les points C2C de type suivant sont visibles:
'hut' => $forums['cabane'],
'shelter' => $forums['abri'],
'summit' => $forums['sommet'],
'pass' => $forums['col'],
'lake' => $forums['lac'],
'locality' => $forums['village'],
(et ça en fait une foule !)

Je n'ai pas jugé utile d'afficher les points de type suivant:
'climbing_outdoor' => 0,
'bisse' => 0,
'access' => 0,
'waterfall' => 0,
'local_product' => 0,
'virtual' => 0,
'misc' => 0
Dominique

mauguier
Messages : 19382
Enregistré le : 27 oct. 2008 08:35

Re: Pic de pollution sur les pictos...?

Messagepar mauguier » 11 déc. 2016 09:50

Fin du pic de pollution et du brouillard... Bravo !
Claude Mauguier


Retourner vers « Fonctionnalités et bugs résolus »